Python--python2与python3共存问题

一、基础知识

1、python2.x 和 python3.x 是可以共存的;

2、python2.x 和 python3.x 两个版本的语法有一些不同,并且python3.x不向下兼容python2.x。

 

二、安装两个版本

1、参考链接

 

三、共存前提下使用单一版本运行.py文件

注:博主的一个版本是python2.7,一个版本是python3.5。

1、方法一:Python hello.py 

a、使用Python2.7时,对应的命令如下

//
python hello.py
//

b、使用Python23.5时,对应的命令如下

//
python3 hello.py
//

2、方法二:编辑 .py 工程文件时,文件头部加入说明语句

a、使用Python2.7时,对应的语句如下,运行时直接python hello.py

//
#! python2
# -*- coding: utf-8 -*-
//

b、使用Python3.5时,对应的语句如下,运行时直接python hello.py

//
#! python3
# -*- coding: utf-8 -*-
//

 

四、共存前提下pip安装对应python版本的模块

1、python2.7 版本安装对应的模块

//
sudo pip install xxxx
//

2、python3.5 版本安装对应的模块

//
sudo pip3 install xxxx
//

3、pip、pip3的安装见傻瓜式安装pip

 

致谢

1、解决python2与python3共存问题

 

 

 

 

展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 技术黑板 设计师: CSDN官方博客
应支付0元
点击重新获取
扫码支付

支付成功即可阅读