linux下ffmpeg安装

1.ffmpeg下载地址: http://www.ffmpeg.org/download.html

2.解压

这里作者假设已经重命名为ffmpeg.tar.bz2

3.解压后进入ffmpeg的文件夹,查看readme, 可以看到和正常的编译安装步骤无异configure && make && make install

ffmpeg编译出错

编译FFMPEG时,出现了 ffmpeg yasm not found, use –disable-yasm for a crippled build,是因为 FFMPEG为了提高编译速度,使用了汇编指令,如果系统中没有yasm指令的话,就会出现上述的问题。
解决办法是:
A 如果是Windows系统, 从网上下载一个 yasm.exe 并安装在mingw/bin下面,重新编译,就不会出现该错误了;
B 如果是Linux系统,则更简单,直接在终端输入 sudo apt-get install yasm (centos 输入sudo yum install yasm),安装好后,重新编译就 OK了

这一次,编译成功, 出现一大串字符, 大致如下:

Selection_007

4.安装

Selection_008

可见直接make install会出现权限问题, 因为之前编译时指定的文件夹是/usr/local/ffmpeg, 所以需要sudo权限

ok,安装成功, 在命令行下试一下命令使用

这时候出现ffmpeg: error while loading shared libraries: libavdevice.so.56: cannot open shared object file: No such file or directory的错误.(部分高版本缺少的是libavdevice.so.54)

我们尝试在系统中找到这个库:

Selection_009

由结果可见, 在我们编译后的/usr/local/ffmpeg/lib/中存在libavdevice.so.56,  我们需要将这个库链接写到/etc/ld.so.conf中然后执行sudo ldconfig, 操作如下:

现在, 全部搞定啦~

链接:抱歉我看找的这文章是转载人的博客,上面没有转载地址,所以抱歉此处只能先不写,以后找到原文出处了,再补上,致谢!

展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 技术黑板 设计师: CSDN官方博客
应支付0元
点击重新获取
扫码支付

支付成功即可阅读